re = /YOUR REGEX HERE/m
str = 'should match: moon, moooon, moooooon, muun, muuuun, moon, moooon
should not match: mn, mooon, mon, mun, muu, oooooon, moouun'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end