using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^b{2}\d{5}$";
string input = @"Bb12345
BB09876
bB45668
bb45678
SA33445
bb123456";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}