$re = '/^b{2}\d{5}$/im';
$str = 'Bb12345
BB09876
bB45668
bb45678
SA33445
bb123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);