import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:Business Date|Date Tripped):\\s*(?:3[01]|[12][0-9]|0?[1-9])\\s+[A-Za-z]+\\s+\\d{4}\\s+(?:\\([^()]+\\)|(?:1[0-2]|0?[1-9]):[0-5]?[0-9]\\s*[AP]M)";
final String string = "Name: Full Report\n"
+ "Store: River North (Wells St)\n"
+ "Date Tripped: 18 Feb 2020 8:40 PM\n"
+ "Business Date: 18 Feb 2020 (Closed)\n"
+ "Message:\n"
+ "Information:\n"
+ "This alert was tripped based on a user defined trigger: Every 5 minutes.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}