const regex = new RegExp('\\b(?:Business Date|Date Tripped):\\s*(?:3[01]|[12][0-9]|0?[1-9])\\s+[A-Za-z]+\\s+\\d{4}\\s+(?:\\([^()]+\\)|(?:1[0-2]|0?[1-9]):[0-5]?[0-9]\\s*[AP]M)', 'gm')
const str = `Name: Full Report
Store: River North (Wells St)
Date Tripped: 18 Feb 2020 8:40 PM
Business Date: 18 Feb 2020 (Closed)
Message:
Information:
This alert was tripped based on a user defined trigger: Every 5 minutes.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}