const regex = /(?<=iPhone 11)(\s*Rs. ).+?(\s\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=iPhone 11)(\\s*Rs. ).+?(\\s\\d*)', 'gm')
const str = `71 Roberts Dr.
Santa Cruz, CA 95060
Tel: +33-1-43-59-55-35.
Quotation for iPhone 11 and iPhone 11 Pro prepared by ABC.
Product list Price per unit
iPhone 11 Rs. 98900
iPhone 11 Pro Rs. 109000
TERMS AND CONDITIONS:
1. Customer will be billed after indicating acceptance of this quote.
2. Payment will be due prior to delivery of service and goods.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}