$re = '/(?<=iPhone 11)(\s*Rs. ).+?(\s\d*)/m';
$str = '71 Roberts Dr.
Santa Cruz, CA 95060
Tel: +33-1-43-59-55-35.
Quotation for iPhone 11 and iPhone 11 Pro prepared by ABC.
Product list Price per unit
iPhone 11 Rs. 98900
iPhone 11 Pro Rs. 109000
TERMS AND CONDITIONS:
1. Customer will be billed after indicating acceptance of this quote.
2. Payment will be due prior to delivery of service and goods.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);