import re
regex = re.compile(r"(\d+)(\,\d+)?(\s)?m[2²]", flags=re.MULTILINE)
test_str = ("appartement de 4 pièces, 2 chambres, 71,52 m²\n"
"appartement de 2 pièces, 1 chambre, 55m²")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")