re = /(\d+)(\,\d+)?(\s)?m[2²]/m
str = 'appartement de 4 pièces, 2 chambres, 71,52 m²
appartement de 2 pièces, 1 chambre, 55m²'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end