#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+)?((?!#\!bin\/bash)#[^#=\)\]\}]+?)$"
Local $sString = "#!bin/bash" & @CRLF & _
"" & @CRLF & _
"# kom" & @CRLF & _
"" # nie kom"#kom" & @CRLF & _
"${zmienna#.?} #kom" & @CRLF & _
"polecenie #komentarz" & @CRLF & _
"polecenie#komentarz" & @CRLF & _
"#" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")