using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)?((?!#\!bin\/bash)#[^#=\)\]\}]+?)$";
string input = @"#!bin/bash
# kom
"" # nie kom""#kom
${zmienna#.?} #kom
polecenie #komentarz
polecenie#komentarz
#
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}