import re
regex = re.compile(r"<style.*</style>", flags=re.MULTILINE | re.DOTALL)
test_str = ("<style data-mw-deduplicate=\"TemplateStyles:r130921360\">.mw-parser-output .ts-fix-template{white-space:nowrap}</style>\n"
"<nostyle data-mw-deduplicate=\"TemplateStyles:r130921360\">.mw-parser-output .ts-fix-template{white-space:nowrap}</nostyle>\n"
"<style data-mw-deduplicate=\"TemplateStyles:r130921360\">.mw-parser-output .ts-fix-template{white-space:nowrap}</style>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")