// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)<style.*</style>").unwrap();
let string = "<style data-mw-deduplicate=\"TemplateStyles:r130921360\">.mw-parser-output .ts-fix-template{white-space:nowrap}</style>
<nostyle data-mw-deduplicate=\"TemplateStyles:r130921360\">.mw-parser-output .ts-fix-template{white-space:nowrap}</nostyle>
<style data-mw-deduplicate=\"TemplateStyles:r130921360\">.mw-parser-output .ts-fix-template{white-space:nowrap}</style>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}