#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(%(25){0,}20|\s)*(%(25){0,}24|\$)(%(25){0,}20|\s)*(%(25){0,}7B|{){0,1}(%(25){0,}20|\s)*(%(25){0,}(6A|4A)|J)(%(25){0,}(6E|4E)|N)(%(25){0,}(64|44)|D)(%(25){0,}(69|49)|I)(%(25){0,}20|\s)*(%(25){0,}3A|:)[\w\%]+(%(25){1,}3A|:)(%(25){1,}2F|\/)[^\n]+"
Local $sString = "${jndi:ldap://" & @CRLF & _
"${jndi:ldaps:/}" & @CRLF & _
"${jndi:rmi:/blarg" & @CRLF & _
"${jndi:dns://" & @CRLF & _
"${jndi:nis://" & @CRLF & _
"${jndi:iiop://" & @CRLF & _
"${jndi:corba://" & @CRLF & _
"${jndi:nds://" & @CRLF & _
"${jndi:http://" & @CRLF & _
"$jndi:https://" & @CRLF & _
" $ { JNDI :ANYPROTOCOL://" & @CRLF & _
" $ { JNDI :ANYPROTOCOL://" & @CRLF & _
"${jNDi:l%252564ap:/ " & @CRLF & _
"" & @CRLF & _
"Breakdown:" & @CRLF & _
"(?i) = case-insensitive" & @CRLF & _
"(%(25){0,}20|\s)* = any number of spaces" & @CRLF & _
"(%(25){0,}24|\$) = $" & @CRLF & _
"(%(25){0,}20|\s)*" & @CRLF & _
"(%(25){0,}7B|{){0,1} = { zero or one time *Updated condition" & @CRLF & _
"(%(25){0,}20|\s)*" & @CRLF & _
"(%(25){0,}(6A|4A)|J) = J" & @CRLF & _
"(%(25){0,}(6E|4E)|N) = N" & @CRLF & _
"(%(25){0,}(64|44)|D) = D" & @CRLF & _
"(%(25){0,}(69|49)|I) =I" & @CRLF & _
"(%(25){0,}20|\s)*" & @CRLF & _
"(%(25){0,}3A|:) = :" & @CRLF & _
"[\w\%]+ = any number of any letters, url encoded or not" & @CRLF & _
"(%(25){0,}3A|:)" & @CRLF & _
"(%(25){0,}2F|\/) = /" & @CRLF & _
"[^\n]+ = until end of line" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")