import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(%(25){0,}20|\\s)*(%(25){0,}24|\\$)(%(25){0,}20|\\s)*(%(25){0,}7B|\\{){0,1}(%(25){0,}20|\\s)*(%(25){0,}(6A|4A)|J)(%(25){0,}(6E|4E)|N)(%(25){0,}(64|44)|D)(%(25){0,}(69|49)|I)(%(25){0,}20|\\s)*(%(25){0,}3A|:)[\\w\\%]+(%(25){1,}3A|:)(%(25){1,}2F|\\/)[^\\n]+";
final String string = "${jndi:ldap://\n"
+ "${jndi:ldaps:/}\n"
+ "${jndi:rmi:/blarg\n"
+ "${jndi:dns://\n"
+ "${jndi:nis://\n"
+ "${jndi:iiop://\n"
+ "${jndi:corba://\n"
+ "${jndi:nds://\n"
+ "${jndi:http://\n"
+ "$jndi:https://\n"
+ " $ { JNDI :ANYPROTOCOL://\n"
+ " $ { JNDI :ANYPROTOCOL://\n"
+ "${jNDi:l%252564ap:/ \n\n"
+ "Breakdown:\n"
+ "(?i) = case-insensitive\n"
+ "(%(25){0,}20|\\s)* = any number of spaces\n"
+ "(%(25){0,}24|\\$) = $\n"
+ "(%(25){0,}20|\\s)*\n"
+ "(%(25){0,}7B|{){0,1} = { zero or one time *Updated condition\n"
+ "(%(25){0,}20|\\s)*\n"
+ "(%(25){0,}(6A|4A)|J) = J\n"
+ "(%(25){0,}(6E|4E)|N) = N\n"
+ "(%(25){0,}(64|44)|D) = D\n"
+ "(%(25){0,}(69|49)|I) =I\n"
+ "(%(25){0,}20|\\s)*\n"
+ "(%(25){0,}3A|:) = :\n"
+ "[\\w\\%]+ = any number of any letters, url encoded or not\n"
+ "(%(25){0,}3A|:)\n"
+ "(%(25){0,}2F|\\/) = /\n"
+ "[^\\n]+ = until end of line\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}