using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\:\n,]+:\d+,?)+";
string input = @"abc:cde,qwe:rty,tyu:asd
abc,cde,qwe:rty.tyu:asd
abcc|dexqwe-rty!tyu(asd
host1:1,23,dsaf,host2:345
host1:1,23,,host2:345,,
host1:1,23,,host2:345
host1:123,host2:345
eos-kfk1-ro-prod.emag.network:9092,eos-kfk2-ro-prod.emag.network:9092,eos-kfk3-ro-prod.emag.network:9092
10.249.34.90:9092,10.249.34.91:9092,10.249.34.92:9092
([^\\:\\n]+:\\d+[,]?)+
([^\:\n]+:\d+)+,?";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}