import re
regex = re.compile(r"([^\:\n,]+:\d+,?)+", flags=re.MULTILINE)
test_str = ("abc:cde,qwe:rty,tyu:asd\n"
"abc,cde,qwe:rty.tyu:asd\n"
"abcc|dexqwe-rty!tyu(asd\n"
"host1:1,23,dsaf,host2:345\n"
"host1:1,23,,host2:345,,\n"
"host1:1,23,,host2:345\n"
"host1:123,host2:345\n"
"eos-kfk1-ro-prod.emag.network:9092,eos-kfk2-ro-prod.emag.network:9092,eos-kfk3-ro-prod.emag.network:9092\n"
"10.249.34.90:9092,10.249.34.91:9092,10.249.34.92:9092\n\n\n"
"([^\\\\:\\\\n]+:\\\\d+[,]?)+\n\n"
"([^\\:\\n]+:\\d+)+,?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")