#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\S+)\R(?=(?:\S+\R)*?\1$)"
Local $sString = "3170059109_usilitel-sluha-sluhovoj.jpg" & @CRLF & _
"3170059111_usilitel-sluha-sluhovoj.jpg" & @CRLF & _
"3170059113_usilitel-sluha-sluhovoj.jpg" & @CRLF & _
"3170059109_usilitel-sluha-sluhovoj.jpg" & @CRLF & _
"3170059111_usilitel-sluha-sluhovoj.jpg" & @CRLF & _
"3170059113_usilitel-sluha-sluhovoj.jpg" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"3683880649_otpugivatel-myshej-pest.jpg" & @CRLF & _
"3175071494_otpugivatel-myshej-pest.jpg" & @CRLF & _
"3683880650_otpugivatel-myshej-pest.jpg" & @CRLF & _
"3683880651_otpugivatel-myshej-pest.jpg" & @CRLF & _
"3683880649_otpugivatel-myshej-pest.jpg" & @CRLF & _
"3175071494_otpugivatel-myshej-pest.jpg" & @CRLF & _
"3683880650_otpugivatel-myshej-pest.jpg" & @CRLF & _
"3683880651_otpugivatel-myshej-pest.jpg" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"3170117180_sportivnyj-topik-ah.jpg" & @CRLF & _
"3170117180_sportivnyj-topik-ah.jpg" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)