import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+)\\R(?=(?:\\S+\\R)*?\\1$)";
final String string = "3170059109_usilitel-sluha-sluhovoj.jpg\n"
+ "3170059111_usilitel-sluha-sluhovoj.jpg\n"
+ "3170059113_usilitel-sluha-sluhovoj.jpg\n"
+ "3170059109_usilitel-sluha-sluhovoj.jpg\n"
+ "3170059111_usilitel-sluha-sluhovoj.jpg\n"
+ "3170059113_usilitel-sluha-sluhovoj.jpg\n\n\n"
+ "3683880649_otpugivatel-myshej-pest.jpg\n"
+ "3175071494_otpugivatel-myshej-pest.jpg\n"
+ "3683880650_otpugivatel-myshej-pest.jpg\n"
+ "3683880651_otpugivatel-myshej-pest.jpg\n"
+ "3683880649_otpugivatel-myshej-pest.jpg\n"
+ "3175071494_otpugivatel-myshej-pest.jpg\n"
+ "3683880650_otpugivatel-myshej-pest.jpg\n"
+ "3683880651_otpugivatel-myshej-pest.jpg\n\n\n"
+ "3170117180_sportivnyj-topik-ah.jpg\n"
+ "3170117180_sportivnyj-topik-ah.jpg\n\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}