#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.?|(..+?)\1+)$"
Local $sString = "1" & @CRLF & _
"22" & @CRLF & _
"333" & @CRLF & _
"4444" & @CRLF & _
"55555" & @CRLF & _
"666666" & @CRLF & _
"7777777" & @CRLF & _
"88888888" & @CRLF & _
"999999999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")