re = /^(?:.?|(..+?)\1+)$/m
str = '1
22
333
4444
55555
666666
7777777
88888888
999999999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end