using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=filename=)[\""]?(\w.*[.].*)(?<=\w)[\""]?";
string input = @"filename=""John_wheeler 11041997 resume.pdf"";
filename=""Kujal_newResume(1).pdf"";
filename=JohnKrasinski_Resume.pdf
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}