import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=filename=)[\\\"]?(\\w.*[.].*)(?<=\\w)[\\\"]?";
final String string = "filename=\"John_wheeler 11041997 resume.pdf\";\n"
+ "filename=\"Kujal_newResume(1).pdf\";\n"
+ "filename=JohnKrasinski_Resume.pdf\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}