import Foundation
let pattern = #"<\d{1,3}>\s*.*?(\S+?)(?:\[\d*\])?\s*:\s*(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<103>CP-MGMT xpand[2859]: Configuration changed from localhost by user admin by the service dbset
<31>routed[4006]: rt_instance_monitor_job: scheduled next instance monitor in 5 seconds
<134>CP_FireWall: 2Jul2017 18:52:23 accept ip address message
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)