package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?test=([^\]]+).*`)
var str = `test=1233]
test=1233]323]
test=1233323abc`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}