re = /.*?test=([^\]]+).*/m
str = 'test=1233]
test=1233]323]
test=1233323abc'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result