package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D+|\D+$`)
var str = `$ 12,345.67 USD`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}