use strict;
my $str = '$ 12,345.67 USD';
my $regex = qr`^\D+|\D+$`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";