package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S*[0-9]+\S*`)
var str = `123 f 123 test123-222 - 1
test 123 test-1 1-1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}