$re = '/\S*[0-9]+\S*/m';
$str = '123 f 123 test123-222 - 1
test 123 test-1 1-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);