package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^TCGA-[A-Z0-9]+-([A-Z0-9]+)$`)
var str = `TCGA-A2-A0T2
TCGA-A2-A0CM
TCGA-BH-A18V
TCGA-BH-A18Q
TCGA-BH-A0E0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}