$re = '/\)([0-9]*)/m';
$str = 'AAa(AAaa13fds3rqfds)222113 Aad(11)2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);