$re = '/^[a-z0-9._]+@gmail\.[a-z]{2,}$/m';
$str = 'example@gmal.com
example@mail.com
user@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);