re = /^[a-z0-9._]+@gmail\.[a-z]{2,}$/m
str = 'example@gmal.com
example@mail.com
user@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end