package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^>]+) >`)
var str = `Report 1 > Page 1
Report 1 > Page 2
Report 2 > Page 4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}