package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)<DIV.+roars.+lions.+DIV> `)
var str = `<DIV
The roars of lions that refuse the chain,
The grunts of bristled boars, and groans of bears,
And herds of howling wolves that stun the sailors' ears.
</DIV> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}