$re = '/<DIV.+roars.+lions.+DIV> /ms';
$str = '<DIV
The roars of lions that refuse the chain,
The grunts of bristled boars, and groans of bears,
And herds of howling wolves that stun the sailors\' ears.
</DIV> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);