#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<author>[^.(]+)(?:\((?<yearf1>\d{4})\)|\.)\s*(?<title>[^?!.]*.)\s*(?<journal>[^0-9,]+)(?<yearf2>\d{4})?[,; ]*(?<issue>[^,: ]*)[,;: ]*(?<pages>\d+(?:[–-]\d+)?)"
Local $sString = "Some AB, Author C, Names DEF,(2018) The title string. T journal name, 10, 560–564" & @CRLF & _
"Some AB, Author C, Names DEF (2018) The title string? T journal name 10:560-564" & @CRLF & _
"Some AB, Author C, Names DEF et al (2018) The title string? T journal name 10:560-564" & @CRLF & _
"Some AB, Author C, Names DEF. The title string. T journal name 2018; 10: 560-564" & @CRLF & _
"Some AB, Author C, Names DEF. The title string. T journal name 2018;10:560-564"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")