re = /^(?:
[dD]{2}[_-]?[mM]{2}[_-]?[yY]{2}(?:[yY]{2})? |
[mM]{2}[_-]?[dD]{2}[_-]?[yY]{2}(?:[yY]{2})? |
[mM]{2}[_-]?[yY]{2}(?:[yY]{2})?[_-]?[dD]{2} |
[dD]{2}[_-]?[yY]{2}(?:[yY]{2})?[_-]?[mM]{2} |
[yY]{2}(?:[yY]{2})?[_-]?[dD]{2}[_-]?[mM]{2} |
[yY]{2}(?:[yY]{2})?[_-]?[mM]{2}[_-]?[dD]{2}
)$/mx
str = 'The expected result is that only combinations such as the following can test true:
dd-mm-yy
MM-DD_YYYY
yyyy_dd-MM
mmddyy
YYYYddMM
YY-mm_dd
YYYY-mm_dd
And not something like:
ddyyyyymmmmmmmmm
mmddyymm
ADDITIONAL no-checks:
mmmmmm
yyyymmmm
yydddd
YYYYddMM-
ddyyyy
yyyymm
yyyydd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end