package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([A-Z]{1})+([[A-Za-z]+[,.]?[ ]?|[A-Za-z]+['-]]?)+$`)
var str = `Joao Pedro Jr.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}