re = /^([A-Z]{1})+([[A-Za-z]+[,.]?[ ]?|[A-Za-z]+['-]]?)+$/
str = 'Joao Pedro Jr.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end