import re
regex = re.compile(r"\s{2,}", flags=re.MULTILINE)
test_str = "Watch me carefully"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)