package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(dog)(?:.+(cat))?`)
var str = `dog, cat
dog, dog, cat
dog, dog, dog
dog, dog, cat, blah`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}