$re = '/^(dog)(?:.+(cat))?/m';
$str = 'dog, cat
dog, dog, cat
dog, dog, dog
dog, dog, cat, blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);