re = /([aA-zZ][aA-zZ][aA-zZ])\s*\-\s*([0-9]{1,2})\s*\-\s*([0-9][0-9])/m
str = 'DEC-17-20'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end