$re = '/\bJOIN\b.*\btable_name\b|\btable_name\b.*\bJOIN\b/';
$str = 'LEFT JOIN table_name column_name ON another_table_name;
table_name LEFT JOIN another table
select * from table_name
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);