// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bJOIN\b.*\btable_name\b|\btable_name\b.*\bJOIN\b").unwrap();
let string = "LEFT JOIN table_name column_name ON another_table_name;
table_name LEFT JOIN another table
select * from table_name
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}