package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d+\.?)(\d+\.)?(\S+)?$`)
var str = `1.0.0-debug`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}