#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z]+(?:[ -][A-Za-z]+)*$"
Local $sString = "A" & @CRLF & _
"Abc" & @CRLF & _
"Abc Xyz" & @CRLF & _
"Abc Xyz VBN" & @CRLF & _
"-Abc-" & @CRLF & _
"-Abc Not XYz" & @CRLF & _
"--------------" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" Abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")