package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]+(?:[ -][A-Za-z]+)*$`)
var str = `A
Abc
Abc Xyz
Abc Xyz VBN
-Abc-
-Abc Not XYz
--------------
Abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}